import re
regex = re.compile(r"\w+/IN\b(\s\w+/(?!IN|:)\w+\b)*\s\w+/(NNP|CDP)\b")
test_str = "Alun-alun/NNP Jombang/NNP tepatnya/RB Depan/IN SMP/NNP 2/CDP Jombang/NNP Besok/NNP pagi/NN Minggu/NNP abc/dev A/NNP"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")