re = /\w+\/IN\b(\s\w+\/(?!IN|:)\w+\b)*\s\w+\/(NNP|CDP)\b/
str = 'Alun-alun/NNP Jombang/NNP tepatnya/RB Depan/IN SMP/NNP 2/CDP Jombang/NNP Besok/NNP pagi/NN Minggu/NNP abc/dev A/NNP'
# Print the match result
str.match(re) do |match|
puts match.to_s
end