using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the ([^t]*(?:t(?!he)[^t]*)*?) area";
string input = @"A popular resource for the Christian community in the Asheville area.
I love the acting community in the Orange County area.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}