import re
regex = re.compile(r"the ([^t]*(?:t(?!he)[^t]*)*?) area")
test_str = ("A popular resource for the Christian community in the Asheville area.\n"
"I love the acting community in the Orange County area.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")