#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[)[^\]\[\r\n]*(?=\])"
Local $sString = "This is a [sample] string with [some] special words. [another one]" & @CRLF & _
"This is a [sample string with [some special words. [another one" & @CRLF & _
"This is a [sample[sample]] string with [[some][some]] special words. [[another one]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")