import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[)[^\\]\\[\\r\\n]*(?=\\])";
final String string = "This is a [sample] string with [some] special words. [another one]\n"
+ "This is a [sample string with [some special words. [another one\n"
+ "This is a [sample[sample]] string with [[some][some]] special words. [[another one]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}