import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<\\?.*?>";
final String string = "<?xml version='1.0' encoding='utf-8'?>\n"
+ "<!--\n"
+ " Licensed to the Apache Software Foundation (ASF) under one or more\n"
+ " contributor license agreements. See the NOTICE file distributed with\n"
+ " this work for additional information regarding copyright ownership.\n"
+ " The ASF licenses this file to You under the Apache License, Version 2.0\n"
+ " (the \"License\"); you may not use this file except in compliance with\n"
+ " the License. You may obtain a copy of the License at\n\n"
+ " http://www.apache.org/licenses/LICENSE-2.0\n\n"
+ " Unless required by applicable law or agreed to in writing, software\n"
+ " distributed under the License is distributed on an \"AS IS\" BASIS,\n"
+ " WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\n"
+ " See the License for the specific language governing permissions and\n"
+ " limitations under the License.\n"
+ "-->\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}