// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b").unwrap();
let string = "entere config here";
let substitution = "$1(removed)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}