import re
regex = re.compile(r"(?:(?:drill|suc+k|lic+k|bang+|stuf+|(?:mother)?fuc*k|fis+t)(?:(?:ing|e[dr])?(?:e?[sz])?)?(?:|\b.{0,80}?\b)(?:pis+|pus+(?:y|ies)|boo+b+|tit+(?:ies)?|coc?k|dick|ass(?:hole)?|penis|phallus|cunt|vag(?:ina)?|genital|ball|rectum|dog+ystyle|blowjob|bitch|bastard|slut+(?:ish)?|harlot|whore|lesbian|queer|homo(?:sexual)?|retard|jew(?:ish)?|nig+(?:er|a)|nic+a|fag(?:g?[eio]t)?|her[ei]tic|idiot|sin+ers|raghead|muslim|hindu|(?:your|him|her|them)\W*sel(?:f|ves))(?:(?:ing|e[dr]|e?)[sz]?)?|(?:pis+|pus+(?:y|ies)|boo+b+|tit+(?:ies)?|coc?k|dick|ass(?:hole)?|penis|phallus|cunt|vag(?:ina)?|genital|ball|rectum|dog+ystyle|blowjob|bitch|bastard|slut+(?:ish)?|harlot|whore|lesbian|queer|homo(?:sexual)?|retard|jew(?:ish)?|nig+(?:er|a)|nic+a|fag(?:g?[eio]t)?|her[ei]tic|idiot|sin+ers|raghead|muslim|hindu|(?:your|him|her|them)\W*sel(?:f|ves))(?:(?:ing|e[dr]|e?)[sz]?)?(?:|\b.{0,80}?\b)(?:drill|suc+k|lic+k|bang+|stuf+(?:ing|ed)|(?:mother)?fuc*k|fis+t)(?:(?:ing|e[dr])?(?:e?[sz])?)?)", flags=re.MULTILINE)
test_str = ("<p>I am afraid this is not easily doable, as modern browsers will block non-HTTPS requests if you are on https website.</p>\n\n"
"<p>I think your best option would be to create your own form, with <code>fromStation</code> and <code>toStation</code> fields, collect this information from user yourself on your website, and then hit the railways website similar way you are doing, but instead of hardcoded URLs, there would be variables provided by the user</p>\n\n"
"<pre><code>$fromStation = $_GET['fromStation']; // this should be sanitized and validated first\n"
"$toStation = $_GET['toStation'];\n\n"
"$content = file_get_contents(\"http://razpisanie.bdz.bg/mobile/search.jsp?fromstation={$fromStation}&tostation={$toStation}\");\n"
"echo $content;\n"
"</code></pre>\n\n"
"<p>This is just a very simple prototype, and you will lose stuff like autocomplete (unless you write it yourself). But unless the Bulgarian railways move their website on https, I am afraid you don't have too many options.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")