re = /(?:(?:drill|suc+k|lic+k|bang+|stuf+|(?:mother)?fuc*k|fis+t)(?:(?:ing|e[dr])?(?:e?[sz])?)?(?:|\b.{0,80}?\b)(?:pis+|pus+(?:y|ies)|boo+b+|tit+(?:ies)?|coc?k|dick|ass(?:hole)?|penis|phallus|cunt|vag(?:ina)?|genital|ball|rectum|dog+ystyle|blowjob|bitch|bastard|slut+(?:ish)?|harlot|whore|lesbian|queer|homo(?:sexual)?|retard|jew(?:ish)?|nig+(?:er|a)|nic+a|fag(?:g?[eio]t)?|her[ei]tic|idiot|sin+ers|raghead|muslim|hindu|(?:your|him|her|them)\W*sel(?:f|ves))(?:(?:ing|e[dr]|e?)[sz]?)?|(?:pis+|pus+(?:y|ies)|boo+b+|tit+(?:ies)?|coc?k|dick|ass(?:hole)?|penis|phallus|cunt|vag(?:ina)?|genital|ball|rectum|dog+ystyle|blowjob|bitch|bastard|slut+(?:ish)?|harlot|whore|lesbian|queer|homo(?:sexual)?|retard|jew(?:ish)?|nig+(?:er|a)|nic+a|fag(?:g?[eio]t)?|her[ei]tic|idiot|sin+ers|raghead|muslim|hindu|(?:your|him|her|them)\W*sel(?:f|ves))(?:(?:ing|e[dr]|e?)[sz]?)?(?:|\b.{0,80}?\b)(?:drill|suc+k|lic+k|bang+|stuf+(?:ing|ed)|(?:mother)?fuc*k|fis+t)(?:(?:ing|e[dr])?(?:e?[sz])?)?)/m
str = '<p>I am afraid this is not easily doable, as modern browsers will block non-HTTPS requests if you are on https website.</p>
<p>I think your best option would be to create your own form, with <code>fromStation</code> and <code>toStation</code> fields, collect this information from user yourself on your website, and then hit the railways website similar way you are doing, but instead of hardcoded URLs, there would be variables provided by the user</p>
<pre><code>$fromStation = $_GET[\'fromStation\']; // this should be sanitized and validated first
$toStation = $_GET[\'toStation\'];
$content = file_get_contents("http://razpisanie.bdz.bg/mobile/search.jsp?fromstation={$fromStation}&tostation={$toStation}");
echo $content;
</code></pre>
<p>This is just a very simple prototype, and you will lose stuff like autocomplete (unless you write it yourself). But unless the Bulgarian railways move their website on https, I am afraid you don\'t have too many options.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end