use strict;
my $str = ' Abc 12$ D Efg ';
my $regex = qr/(?<=\S)\s+(\s\S|$)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";