$re = '/(?<=\S)\s+(\s\S|$)/m';
$str = ' Abc 12$ D Efg ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;