#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?=\()(?:(?=(?(1).*?(?=\1)).*?\((.*))(?=(?(2).*?(?=\2)).*?\)(.*)).)+?(?>.*?(?=\1))[^(]*?(?=\2$)"
Local $sString = "Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo" & @CRLF & _
"( Matches (can (even" & @CRLF & _
"span ) multiple ) " & @CRLF & _
"lines! ) yeah buddy!!" & @CRLF & _
"(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")