import re
regex = re.compile(r"^(?:.*?\K\b[0-9]{9}\b){2}", flags=re.MULTILINE)
test_str = "hash=e1467eb30743fb0a180ed141a26c58f7&token=a62ef9cf-2b4e-4a99-9335-267b6224b991:FC:BZCA:117804471:EUR:false:en:vs7monkeys:117804471&providerId=pragmaticplay"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")