re = /^(?:.*?\K\b[0-9]{9}\b){2}/m
str = 'hash=e1467eb30743fb0a180ed141a26c58f7&token=a62ef9cf-2b4e-4a99-9335-267b6224b991:FC:BZCA:117804471:EUR:false:en:vs7monkeys:117804471&providerId=pragmaticplay'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end