using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w[^,=]*)=(.*?)(?=]|,\s*\w[^,=]*=)";
string input = @"[key1=value1, key2=value2]
[key1=value1, key2=value2, key 3= text, value # 3, key4=value4]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}