$re = '/(\w[^,=]*)=(.*?)(?=]|,\s*\w[^,=]*=)/m';
$str = '[key1=value1, key2=value2]
[key1=value1, key2=value2, key 3= text, value # 3, key4=value4]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);