using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABC.*?(?=ABC|$)";
string input = @"123ABC97edfABCaaabbdd1234ABC0009ui50ABC_1234
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}