$re = '/ABC.*?(?=ABC|$)/';
$str = '123ABC97edfABCaaabbdd1234ABC0009ui50ABC_1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);