import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<ID>[A-Z][A-Z0-9]{3})?(?P<REF1>(?:(?!//).)+)(//(?P<REF2>.+))?(\\n?(?P<EXTRA>.+))?$";
final String string = "TEX1CNS0P5-AA//CAT-523-VID-00EOS-0\n"
+ "XUX PETER LAB RANDOM TEXT DM5.\n\n"
+ "TEX2BFTBSH9999SBRT2L\n"
+ "RATRACE201\n\n"
+ "TEX3GWS0P2-AA//D-14839048-99-3\n"
+ "THERE WAS 200 COALS IN HIS STOCKING.\n\n"
+ "TEX4POF OF 20/03/09//CAT342134832489\n"
+ "P/O:1600 PARK AVENUE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}