import re
regex = re.compile(r"^(?P<ID>[A-Z][A-Z0-9]{3})?(?P<REF1>(?:(?!//).)+)(//(?P<REF2>.+))?(\n?(?P<EXTRA>.+))?$", flags=re.MULTILINE)
test_str = ("TEX1CNS0P5-AA//CAT-523-VID-00EOS-0\n"
"XUX PETER LAB RANDOM TEXT DM5.\n\n"
"TEX2BFTBSH9999SBRT2L\n"
"RATRACE201\n\n"
"TEX3GWS0P2-AA//D-14839048-99-3\n"
"THERE WAS 200 COALS IN HIS STOCKING.\n\n"
"TEX4POF OF 20/03/09//CAT342134832489\n"
"P/O:1600 PARK AVENUE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")