import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\h]+)\\h*(?:(OPS|EC5|CSP|PBF|PVF)(?:([^\\h])\\h|([^\\h]{2})|\\h{2}))(?:([^\\h]{2})|\\h{2})\\h([^\\h]+)\\h+(.{4})\\h(.{5})\\h(.{10})\\h";
final String string = "7089 OPS 7089 1 / aar both all \n"
+ "7901 OPS 7901 1 / aar both all \n"
+ "90510 EC500 467012312312345 3 / ars both all \n"
+ "906101PVFMC46 701234567 12/ ars both all \n"
+ "90-71011CSP 46 707123457 12/ ars both all ";
final String subst = "$1|$2$3$4|$5|$6|$7|$8|$9|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}