$re = '/[a-z]([A-Z])\./m';
$str = 'hello worldB. What are you doing now
hello worldB.What are you doing now
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);