re = /[a-z]([A-Z])\./m
str = 'hello worldB. What are you doing now
hello worldB.What are you doing now
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end