import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?=[6-9](?<1>){6}|)(?=[3-59](?<1>){3}|)(?=[258](?<1>){2}|)(?=[147](?<1>)|).)+$(?<!(?=(?<-1>.)+(?(1)^))\\11(?=((?<=(?=(?=((?<-2>)(?=.*$((?<-2>\\2)(?<3>)|){9}).)+(?(2)^))(?>(?<-1>)(.)(?<=((?<5-1>\\1)|){9}^.*))*(?<2>.(?<=((?<5>)(?<-1>\\1)|){9}((?<-1>\\1){10}|())((?<2-1>)(?<-3>\\3)|){9}(?<-9>(?<-1>))?(?<1>){10}(?<-3>)(?<-1>)(?<5>^.*)))+$(?!\\9)(?(3)^)(?<=(?<-5>(?=(?<1>(?=.*$\\5)|.)).)*){10}(\\12)?()|){9}^.*).)*)(?<-13>){2}\\13(?<-13>)^(?<-14>(?(14)|((?<2>(.)?))){10}(?<-15>))+(?<15>)(.)*|^1)";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "17\n"
+ "18\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "22\n"
+ "23\n"
+ "9971\n"
+ "9973\n"
+ "9977";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}