package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(Set Cookie:|Set-Cookie:|HTTP|200 OK|Cookie:|document\.?cookie).*$`)
var str = `svc_test
adm_test
eac_test
passaccount
pass_fail
pa_ssfail
Set Cookie:
Set-Cookie: <cookie-name>=<cookie-value>
HTTP/2.0 200 OK
document.cookie
//ES5
if (document.cookie.split(';').some(function(item) {
return item.trim().indexOf('reader=') == 0
})) {
console.log('The cookie "reader" exists (ES5)')
}
//ES2016
if (document.cookie.split(';').some((item) => item.trim().startsWith('reader='))) {
console.log('The cookie "reader" exists (ES6)')
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}