const regex = /^.*(Set Cookie:|Set-Cookie:|HTTP|200 OK|Cookie:|document\.?cookie).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(Set Cookie:|Set-Cookie:|HTTP|200 OK|Cookie:|document\\.?cookie).*$', 'gm')
const str = `svc_test
adm_test
eac_test
passaccount
pass_fail
pa_ssfail
Set Cookie:
Set-Cookie: <cookie-name>=<cookie-value>
HTTP/2.0 200 OK
document.cookie
//ES5
if (document.cookie.split(';').some(function(item) {
return item.trim().indexOf('reader=') == 0
})) {
console.log('The cookie "reader" exists (ES5)')
}
//ES2016
if (document.cookie.split(';').some((item) => item.trim().startsWith('reader='))) {
console.log('The cookie "reader" exists (ES6)')
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}