#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)=(.*?)(?=\s\w+=|$)"
Local $sString = "Nov 6 07:16:52 delinea-gp2 CEF:0|Thycotic Software|Secret Server|11.6.000012|10200|PLATFORM - SYNCHRONIZE|2|msg=[[SecretServer]] Event: [Platform] Action: [Synchronize] By User: ThycoticSystem Details: Platform Sync Initiated suid=1 suser=ThycoticSystem cs4=ThycoticSystem cs4Label=suser Display Name rt=Nov 06 2023 07:16:48"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")