$re = '/(\w+)=(.*?)(?=\s\w+=|$)/m';
$str = 'Nov 6 07:16:52 delinea-gp2 CEF:0|Thycotic Software|Secret Server|11.6.000012|10200|PLATFORM - SYNCHRONIZE|2|msg=[[SecretServer]] Event: [Platform] Action: [Synchronize] By User: ThycoticSystem Details: Platform Sync Initiated suid=1 suser=ThycoticSystem cs4=ThycoticSystem cs4Label=suser Display Name rt=Nov 06 2023 07:16:48';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);