$re = '/^(x*)(x[^x]+x)(\1)$/m';
$str = 'x...x
^^^^^
xx...x
xxx...xxx
^^^^^
xxxx...xxxx
^^^^^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);