re = /^(x*)(x[^x]+x)(\1)$/m
str = 'x...x
^^^^^
xx...x
xxx...xxx
^^^^^
xxxx...xxxx
^^^^^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end