$re = '/^.*\b(\d+)/m';
$str = 'My ID is 112243 and my phone number is 0987654321. Thanks you.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);