re = /^.*\b(\d+)/m
str = 'My ID is 112243 and my phone number is 0987654321. Thanks you.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end