$re = '/^\b[\w\.\-]+@(?!rubd)[\w\.\-]+\.(?:com|net|org|edu)\b$/mi';
$str = 'dgh@rubd.com
ads@gmail.com
ert@ruba.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);