re = /^\b[\w\.\-]+@(?!rubd)[\w\.\-]+\.(?:com|net|org|edu)\b$/mi
str = 'dgh@rubd.com
ads@gmail.com
ert@ruba.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end