#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?x)" & @CRLF & _
".+(?:Sub|Function)\ (\w+)\( # method declaration" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
"(?: # start of parameter pattern" & @CRLF & _
"[\w\W]*?(?<=\b) # parameter may be preceded by ByVal or Optional keywords" & @CRLF & _
"([a-z]\w+)+ # parameter starts with a lower case" & @CRLF & _
".*? # parameter may be followed by its type declaration" & @CRLF & _
"(?:=\ ([^\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call" & @CRLF & _
"(?:,|\)) # parameter is followed by , or )" & @CRLF & _
"){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)" & @CRLF & _
""
Local $sString = "Public Function BrowseToDictTreeNode(ByVal rootNode As Scripting.Dictionary, ByVal browseKey As String, ByVal nodeUrl As String, _" & @CRLF & _
" Optional ByVal urlSlash As String = "/", Optional ByVal childrenKey As String = "Children", _" & @CRLF & _
" Optional ByVal startAtLevel As Integer = 1) As Scripting.Dictionary" & @CRLF & _
""
Local $sSubst = "#Sub call\n$1 $2:=$3, $4:=$5, $6:=$7, $8:=$9, $10:=$11, $12:=$13, $14:=$15, $16:=$17, $18:=$19, $20:=$21, $20:=$21, $22:=$23, $24:=$25\n\n#Function call\n$1($2:=$3, $4:=$5, $6:=$7, $8:=$9, $10:=$11, $12:=$13, $14:=$15, $16:=$17, $18:=$19, $20:=$21, $20:=$21, $22:=$23, $24:=$25)\n\n#Recursive Sub call\n$1 $2:=$2, $4:=$4, $6:=$6, $8:=$8, $10:=$10, $12:=$12, $14:=$14, $16:=$16, $18:=$18, $20:=$20, $22:=$22, $24:=$24, \n\n#Recursive Function call\n$1($2:=$2, $4:=$4, $6:=$6, $8:=$8, $10:=$10, $12:=$12, $14:=$14, $16:=$16, $18:=$18, $20:=$20, $22:=$22, $24:=$24, )"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)