import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ ".+(?:Sub|Function)\\ (\\w+)\\( # method declaration\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n"
+ "(?: # start of parameter pattern\n"
+ "[\\w\\W]*?(?<=\\b) # parameter may be preceded by ByVal or Optional keywords\n"
+ "([a-z]\\w+)+ # parameter starts with a lower case\n"
+ ".*? # parameter may be followed by its type declaration\n"
+ "(?:=\\ ([^\\,]+)){0,1} # optional parameters may be followed by default value, it is captured to be used in method call\n"
+ "(?:,|\\)) # parameter is followed by , or )\n"
+ "){0,1} # end of parameter pattern (may be copy-pasted infinitely to capture all parameters)\n";
final String string = "Public Function BrowseToDictTreeNode(ByVal rootNode As Scripting.Dictionary, ByVal browseKey As String, ByVal nodeUrl As String, _\n"
+ " Optional ByVal urlSlash As String = \"/\", Optional ByVal childrenKey As String = \"Children\", _\n"
+ " Optional ByVal startAtLevel As Integer = 1) As Scripting.Dictionary\n";
final String subst = "#Sub call\\n$1 $2:=$3, $4:=$5, $6:=$7, $8:=$9, $10:=$11, $12:=$13, $14:=$15, $16:=$17, $18:=$19, $20:=$21, $20:=$21, $22:=$23, $24:=$25\\n\\n#Function call\\n$1($2:=$3, $4:=$5, $6:=$7, $8:=$9, $10:=$11, $12:=$13, $14:=$15, $16:=$17, $18:=$19, $20:=$21, $20:=$21, $22:=$23, $24:=$25)\\n\\n#Recursive Sub call\\n$1 $2:=$2, $4:=$4, $6:=$6, $8:=$8, $10:=$10, $12:=$12, $14:=$14, $16:=$16, $18:=$18, $20:=$20, $22:=$22, $24:=$24, \\n\\n#Recursive Function call\\n$1($2:=$2, $4:=$4, $6:=$6, $8:=$8, $10:=$10, $12:=$12, $14:=$14, $16:=$16, $18:=$18, $20:=$20, $22:=$22, $24:=$24, )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}