#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Z]+$|[a-z]+$)(?i:aaa|bbb|ccc)"
Local $sString = "AAA" & @CRLF & _
"aaa" & @CRLF & _
"BBB" & @CRLF & _
"bbb" & @CRLF & _
"CCC" & @CRLF & _
"ccc" & @CRLF & _
"AaA" & @CRLF & _
"aAa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")