$re = '/^(?=[A-Z]+$|[a-z]+$)(?i:aaa|bbb|ccc)/m';
$str = 'AAA
aaa
BBB
bbb
CCC
ccc
AaA
aAa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);