#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/\[([A-Za-z0-9])(?!\1)([A-Za-z0-9])(?!\2)([A-Za-z0-9])\]\/$"
Local $sString = "/[Ab9]/" & @CRLF & _
"/[aC9]/" & @CRLF & _
"/[a8Z]/" & @CRLF & _
"/[8zZ]/" & @CRLF & _
"/[ZzZ]/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")