$re = '/^\/\[([A-Za-z0-9])(?!\1)([A-Za-z0-9])(?!\2)([A-Za-z0-9])\]\/$/m';
$str = '/[Ab9]/
/[aC9]/
/[a8Z]/
/[8zZ]/
/[ZzZ]/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);