$re = '/(?<=\|)([^\|]+)(?=\||$)/m';
$str = '| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Minivan |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);