re = /(?<=\|)([^\|]+)(?=\||$)/m
str = '| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Minivan |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end