package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\S+\s?){1,2})(?:\s|$)`)
var str = `Hello this is text hello how r u`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}