$re = '/((?:\S+\s?){1,2})(?:\s|$)/m';
$str = 'Hello this is text hello how r u';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);