const regex = /^((0?\d)|([12]\d)|(3[01]))?\.?((0?\d)|(1[012]))?\.?((\d)|(\d\d)|(\d{3})|(19\d\d)|(20[0-3]\d))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0?\\d)|([12]\\d)|(3[01]))?\\.?((0?\\d)|(1[012]))?\\.?((\\d)|(\\d\\d)|(\\d{3})|(19\\d\\d)|(20[0-3]\\d))?$', 'gm')
const str = `23.04.1988
5.9.11
12.12.20
02.02.02
02.02.0
02.02.
02.02
02
9
32.02.1999
12.13.2017
a2.03.2017
5.13.
12.12.1880
12.12.2100
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}