import re
regex = re.compile(r"^((0?\d)|([12]\d)|(3[01]))?\.?((0?\d)|(1[012]))?\.?((\d)|(\d\d)|(\d{3})|(19\d\d)|(20[0-3]\d))?$", flags=re.MULTILINE)
test_str = ("23.04.1988\n"
"5.9.11\n"
"12.12.20\n"
"02.02.02\n"
"02.02.0\n"
"02.02.\n"
"02.02\n"
"02\n"
"9\n\n"
"32.02.1999\n"
"12.13.2017\n"
"a2.03.2017\n"
"5.13.\n"
"12.12.1880\n"
"12.12.2100\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")