#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z]+) *?\$?([0-9]+) ?([a-zA-Z]*)"
Local $sString = "Text Column" & @CRLF & _
"The doctor has advised the patient to pay $200 for the treatment" & @CRLF & _
"Patient submitted the $200 operation fee but not the admit fee $100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")