const regex = new RegExp('([a-zA-Z]+) *?\\$?([0-9]+) ?([a-zA-Z]*)', 'gm')
const str = `Text Column
The doctor has advised the patient to pay \$200 for the treatment
Patient submitted the \$200 operation fee but not the admit fee \$100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}