import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<)([^\\/>]+)>(.+)(?=<)";
final String string = "</data>\\<data xmlns=\"\">\n"
+ "<color>blue green</color>\n"
+ "<install>No</install>\n"
+ "<days>4</start>\n"
+ "</data>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}